BFT command from one RFLink not recognized by another RFlink

French support forum, post can be done in French, answers will either be in French or in English.

Moderators: rtenklooster, Voyager, BertB, Stuntteam, Deennoo

Post Reply
Message
Author
Stephane
Normal user
Posts: 4
Joined: 30 Apr 2021, 09:31

BFT command from one RFLink not recognized by another RFlink

#1 Post by Stephane » 30 Apr 2021, 10:35

Hi guys,

I just started playing around with RFlink and my old remotes from here and there in the house :)

I actually have 2 RFlinks up&running.

Here's my issue :
  • Both RFlinks are usng RLink Firmware Version: 1.1 Revision: 48
  • Both RFLink1 and RFLink2 are plugged to their own PC with RFLink Loader V1.11 up&running
  • I took one of my existing remotes (gate opener) and pressed the button => Both RFLink Loader from RFLink1 and RFLink2 decode the signal and both tell me it's

    Code: Select all

    20;1A;BFT;ID=103e0;SWITCH=1;CMD=ON;
Brilliant 8-)
  • From RFLink1, I enter

    Code: Select all

    10;BFT;103e0;1;ON;
    in the "Command To Send" field and press "Send Command"
re-brilliant 8-)
  • On RFLink2, I would expect the command to be recognized but... nothing happens... :shock:
  • If I enable "Log Debug" on RFLink2 and resend the command from RFLink1, I receive the following frames :

    Code: Select all

    20;16;DEBUG;Pulses=286;Pulses(uSec)=1230,870,870,930,840,990,810,990,840,960,810,330,1380,420,1350,450,1350,450,1350,450,1350,480,1350,1140,660,3270,1080,1170,630,1170,630,1170,660,1170,630,1170,630,510,1290,510,1290,510,1290,540,1260,540,1260,570,1260,1200,600,3330,1050,1200,600,1200,630,1200,600,1200,600,1200,600,540,1260,540,1260,540,1260,570,1260,570,1260,570,1260,1230,600,3330,1050,1230,600,1230,600,1230,600,1230,600,1200,600,540,1260,540,1260,570,1260,540,1260,570,1260,570,1260,1230,600,3330,1050,1230,600,1230,600,1230,600,1200,600,1200,600,570,1260,540,1260,570,1260,570,1260,570,1260,570,1260,1230,600,3330,1050,1230,570,1230,570,1230,570,1230,600,1200,600,540,1260,540,1260,540,1260,570,1260,570,1230,600,1230,1260,540,3360,1020,1230,570,1230,570,1230,570,1230,600,1230,600,570,1230,600,1230,600,1200,600,1200,600,1200,600,1200,1260,540,3360,1020,1230,570,1230,570,1230,570,1230,600,1230,600,570,1260,570,1230,570,1260,570,1230,570,1230,570,1260,1230,570,3330,1020,1200,600,1200,600,1200,600,1200,600,1200,600,540,1260,540,1260,540,1260,540,1260,540,1260,540,1260,1230,600,3330,1050,1200,600,1200,600,1200,600,1200,600,1200,600,540,1260,540,1260,540,1260,540,1260,540,1260,540,1260,1230,600,3330,1050,1200,600,1200,600,1200,600,1200,600,1200,600,540,1290,540,1290,540,1290,540,1260,540,1260,540,1260,1200,600,6990;
  • If I click the button on the remote while still being on debug mode, RFLink2 says :

    Code: Select all

    20;5D;DEBUG;Pulses=26;Pulses(uSec)=750,1170,690,1170,660,1170,660,1170,690,1170,660,510,1320,540,1320,540,1320,540,1320,540,1320,540,1290,1230,630,6990;
    which is obviously quite a different message
NB : It behaves exactly the same the other way around if I use RFLink2 as the emitter and RFLink1 as the receiver.

And now the big question, what am I doing (or understanding) wrong? :)

Many thanks in advance for any insights ;)

Stéphane

User avatar
Stuntteam
Site Beheer
Posts: 691
Joined: 27 Jan 2016, 16:46

Re: BFT command from one RFLink not recognized by another RFlink

#2 Post by Stuntteam » 30 Apr 2021, 12:29

When RFLink sends the BFT command, does the gate respond?
-=# RFLink Gateway Development Team #=-
Introduction: http://www.nemcon.nl/blog2/
Generic Support forum: http://www.esp8266.nu/forum/viewforum.php?f=8

Stephane
Normal user
Posts: 4
Joined: 30 Apr 2021, 09:31

Re: BFT command from one RFLink not recognized by another RFlink

#3 Post by Stephane » 30 Apr 2021, 12:41

Hi and thanks for your swift reply !

Indeed good question and I should have put it in my post :lol:

No the gate does not respond. In fact, it's because the gate wasn't responding at first that I assembled a 2nd RFLink to see if my 1st one was actually emitting something.

Stéphane

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest